You are running PHP 5.5.9-1ubuntu4.14, but Grav needs at least PHP 5.6.4 to run.